Підтримка24

Важливо! Можливі проблеми з підключенням до сайтів, магазинів Бітрікс24 з 30 вересня 2021

З 30 вересня 2021 17:01 за київським часом можуть спостерігатися проблеми у клієнтів зі старою версією браузерів або операційної системи, а також на власних серверах або хостингу:

  • при підключенні до сайтів і магазинів Бітрікс24;
  • при підключенні до Бітрікс24 з послугою «власний домен» (тарифи «Професійний» і архівний «Компанія»);
  • при виконанні API REST-запитів зі свого сервера до Бітрікс24.

Це пов'язано з тим, що сертифікат DST Root CA X3 бере участь у ланцюжку клієнтських сертифікатів які видаються нами від Let's Encrypt, і буде залишений до 2024 року для підтримки пристроїв з Android версій 2.3.6-7.1.1.


Що робити?

Єдине правильне рішення – використання актуального ПО клієнтами. Іншими словами, оновіть ваші пристрої і браузери до останніх версій.

Якщо ви використовуєте віртуальну машину VMBitrix на своєму сервері, то необхідно оновити пакет ca-certificates за допомогою команди:

yum update -y ca-certificates

Якщо ви використовуєте інше серверне оточення, то зверніться до системного адміністратора вашого сервера.

Підключення до сайтів і порталів

Проблема не торкнеться:

  • Windows >= XP SP3 (з автоматичним оновленням)
  • macOS >= 10.12.1
  • iOS >= 10
  • Android >= 7.1.1
  • Mozilla Firefox >= 50.0
  • Ubuntu >= xenial / 16.04 (с обновлениями)
  • Debian >= jessie / 8 (с обновлениями)
  • Java 8 >= 8u141
  • Java 7 >= 7u151
Робота браузерів Chrome, Safari, Edge, Opera, Vivaldi буде залежати від версії ОС, на якій вони встановлені.

У всіх інших випадках можуть спостерігатися проблеми з підключенням. Буде видаватися помилка про закінчення терміну дії сертифікатів при спробі входу на сайти, магазини Бітрікс24 і портали зі своїм доменом.


Виконання REST/API запитів

Проблема буде, в основному, зачіпати клієнтів при виконанні API-запитів з серверів зі старим ПЗ, які використовують:

  • openssl-1.0.1 – повністю несумісний і працювати не буде без збору власних пакетів (CentOS 6).
  • openssl-1.0.2 – необхідно оновити пакет ca-certificates на серверах (CentOS 7).
  • openssl-1.1.x – повністю сумісний.

Для вирішення цієї проблеми, зверніться до системного адміністратора вашого сервера.


Детальніше про сумісність кореневого сертифіката DST Root CA X3 з пристроями і операційними системами можна прочитати в документації Let's Encrypt.
Допомогло!
Дякуємо :)
Необов'язково:
Залишити відгук про статтю
Не допомогло
Дуже шкода :(
Дізнайтесь, чому:
Залишити відгук про статтю
Маю додаткові запитання
Замовити впровадження